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SUBJECT:  FILE MANAGEMENT KEYWORDS: DATA MANAGEMENT, FILE STRUCTURING 

SOLIDWORKS FILE MANAGEMENT 
The aim of this document is to provide the reader with an understanding of how the SolidWorks file structure and management 
works. It is loosely based upon the SolidWorks File Management training course. 
 

SolidWorks File Structure 
In order to properly manage SolidWorks file or use any PDM (Product Data Management) system in SolidWorks, it is important to 
know what is contained in a SolidWorks file and how they relate to one another. 
A SolidWorks file is structured as a single point database. This means that when a part is used in an assembly, for example, the 
assembly purely references that part rather than copying the information to itself. It is this which keeps the file size of assemblies 
down. These references are known as absolute meaning they relate to a folder/ directory path on your computer or server, hence 
why it is vital NOT to move files from folder to folder without the use of a PDM system. 
 
A SolidWorks file contains four sets of information: 
 Header: information about the file such as its format, file name, type, size and properties 
 Instructions Set: can be thought of as the FeatureManager Tree in a listed format, this is what is used to build the file 

Database: The modelling kernel that build the files outputs a database that consists of the topology (shape) which we see in 
the form of the graphics of the model 
Visualisation Data: This is the data used to preview models and the image seen on screen 

 
Knowing the structure of a SolidWorks file can help easily reduce the file size of a model using simple techniques. 
The Database and Visualisation data contribute to file size and the mode complex a model is (graphically) the bigger the Database 
and Visualisation data will be. An easy way to reduce this is to simplify the graphics.  
One way of doing this is using a technique called Blocking a model. All this does is creates a rectangular block that is extruded over 
the extremities of the model. This can be sent to a colleague at the reduced file size, opened and the block feature can be simply 
deleted leaving behind the original geometry: 
 
  

 

 

 

 

 

Original File ~3MB   Blocked File~ 1.5MB  Suppress/ Delete the feature on receipt 

The other method of reducing file sizes is to suppress features that contribute the most to overall rebuild time. 
Use Tools> Feature Statistics to diagnose the features in rebuild order (both % and seconds) and then suppress them. Not only will it 
speed up the general day to day working on the file, but reduce the file size. An even bigger file saver is to suppress everything in the 
tree, the file from above reduces to 350KB when this is done!! This is because there is literally no Database and Visualisation data in 
the part but all the history is still kept in the Instructions set. 
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FeatureManager Design Tree 
As well as showing you a visual representation of the order and chain of 
commands used to build a model, the Feature Tree is also ordered 
according to how the Instructions set build the model when opened. 
 

1. Establish the reference geometry (Origin and Plane positions) 
 

2. Load all the parts and sub assemblies into memory 
 

 
 
 
 
 

3. Assemble the parts using the instructions in the mates list 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Solve in context and assembly features such as patterns 

 

 

An example of the SolidWorks file referencing 

structure can be seen to the right. Some of the 
references can be a link or an embedded file. 
On any assembly or drawing file you can view the 
references by using File> Find References 
From here Copy Files can be selected which 
launches the Pack and Go function which enables 
you to copy all files and references to a new 
location 
To find any External References (-> symbol) right 
mouse click the part name and choose List External 
Refs. 
 
Tip: unique file names are the key to managing 
files in SolidWorks. Only one document of a given 
name can be open at any one time. 
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File Conversion 
The SolidWorks file structure changes with each major release, which is the main reason why SolidWorks files are not back 
compatible. The file structure is only changed to the new release when the file is saved in the new version. This file conversion means, 
initially opening the file may take a little longer, to automate the conversion use the SolidWorks Task Scheduler, an add-in of 
SolidWorks Professional (START> All Programs> SolidWorks 2009> SolidWorks Tools). Here there are a variety of tasks that can be 
ran when you are out of the office by specifying a folder where you want the action to take place. 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

RAM Resident opening of files 
When a parent document is opened, all of the referenced documents are also loaded into RAM. You may have seen that when you 
make changes to a part it will update the loaded assembly. If you choose to close that part and NOT save, the assembly will still show 
the newer part, as it is loaded into RAM. The way to get this back to normal (without closing a reopening everything) is to use Reload. 
By selected the part that needs reloading and selecting File> Reload the file saved on disk will be copied into RAM overwriting the 
existing version. 
 

Saving Files 
Save  copies the file in RAM to disk, leaving the RAM version open. 
Save As copies the file in RAM to disk with a new name. The old version (that was in RAM) is closed without saving and any 

open documents that reference this file are updated with the new reference 
Save As Copy copies the file in RAM to disk with a new name, leaving the existing RAM version (old name) open. No additional 

references are updated  
 
Editing references on Open 
References can be changed when a file is opened, i.e. change the part a drawing references. 
Choose File> Open and select the assembly or drawing document by left clicking once. Select References in the bottom right corner of 
the dialogue and you will be shown the current references. Double click the reference to change and browse for its replacement. The 
file name turns green indicating a change to the reference. 
Back Ups and Recovery 
SolidWorks provides methods of regaining lost information through backups and Autorecover files. That said it is always advised to 
Save regularly and often to avoid losing work, this may be even more apparent if saving across a network. Set the options through 
Tools> Options> System Options> Backup/ Recover 
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Backup  Backups are additional copies of SolidWorks files optionally saved to an alternative location. The backup is the 
version before the last save. You can save up to 10 backups of each document and set to clear them out after a certain number of 
saves. 
AutoRecover Automatically saves information about the active file which can be redeemed after an unexpected termination or 
crash. AutoRecover is different to AutoSave as the Recover tool can be set after a certain number of rebuilds or a certain amount of 
time. AutoRecover information is only available after an unexpected crash where it will be available on the AutoRecover tab on the 
RHS of the screen. 
Save Notification Provides an on screen prompt after a set amount of time of changes reminding you to save. 
 
It is advised to set the locations for Backups and AutoRecover to a local directory instead of a network, as a network drop out could 
let to file corruption or “Fail to Save” issues. 
 

File Properties (Metadata) 
File properties are details about a file that helps identify it e.g. a descriptive title, author etc. They also provide additional search 
criteria to which you can find files. As well as Windows™ based properties, SolidWorks provides its own more suited to engineering 
such as revision, Checked By etc. 
Classes of properties 
 Automatic- maintained by the application included date created, last modified date, and file size 
 Preset- properties that exist but need to be filled in by the user 
 Custom- defined by the user and applied to entire document (part, assemblies and drawings) 
 Configuration Specific- defined by the user but applied to one configuration only 
 SolidWorks Custom Properties- These are automatically updated by SolidWorks including the parts mass, material etc. 
 
There are a variety of ways of adding properties to SolidWorks files which include:  
Windows Explorer (RMB Properties on the file) 
Custom Properties Tab in SolidWorks (File> Properties) 
Design Tables within SolidWorks using the syntax $PRP@property 
SolidWorks Workgroup PDM during the check in process 
SolidWorks Enterprise PDM defined by variables on data/ template cards. 
 
Properties can be used in a variety of ways: 
Create parametric notes and annotations in parts, assemblies and notes. The notes will update as the property does 
Advanced Selection and Show/Hide in Assemblies- can select parts based on the custom property value 
Populate drawing borders and title blocks, as well as BOMs, and revision tables. 
 
The list of properties available when selecting from the Property Name field from File> Properties is governed by a text file residing 
on your system. Check the location using Tools> Options> File Locations> Custom Property Files. If you want to reduce the list to only 
the properties that interest you, edit the text file and delete/ add rows as required (take a backup of original beforehand) 
 
 

 

 

 

 

File References 
Knowing the SolidWorks reference order is useful for determine how SolidWorks reads in files. It takes the reference purely based on 
file names using the following hierarchy order: 

1. RAM- if a file of the correct name is already open, it will use this file, reiterating the need to use unique file names 
2. Directories set in Tools> Options> File Locations> Referenced Documents-setting these additional directories can speed 

up finding files if you specify the location you normally save files to 
3. The last path you opened a file from- When a parent document is opened, SW will search the same location for the 

children 
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4. The last path the system used to open a file- this applies if the system automatically opened a reference document last 
5. The path where the reference document was located when the parent document was last saved- in case the parent 

document was moved. This excludes the drive (C:, D:) location 
6. The path where the reference document was located when the parent was last saved with the original drive 

destination- as above but with the absolute path 
7. If still not found, a message appears asking you to browse for it yourself. 

Once re-linked to a missing document (moved or renamed using Windows Explorer) using step 7, the next save operation will 
update the new references. 
 
Changing References 
There are many occasion where you need to exchange a part or sub assembly for a replacement 

File> Save As changes the references of the open assembly to the newly resaved part/ subassy with the new 
name 

 File> Replace  Allows substitution of a selection or all instances of one component with an alternative 
File> Open>References Changes the reference before the document is opened (page 3) 
File> Save As> References When a parent document is saved, the children can be saved to new names and so new 

documents 
SolidWorks Explorer Has the ability to rename files and tell any reference documents about the name change to ensure 

the reference is updated without error. The files do not need to be open to perform this function 
 
External References 
There are more considerations needed when resaving assemblies that contain external references. When we perform a Save As on an 
assembly that contains external references we receive a message as follows: 

There are parts that have features defined in the context of <assembly path 

and name>. If you select OK to continue this operation these features will 

not update in the context of the newly created assembly. It is highly 

recommended you consider saving new versions of these parts now which will 

update in the context of this newly saved assembly. To do this, select 

Cancel, select References from the Save As dialog box, then input new names 

for those parts that you want to update in the new assembly. 

 

The highlighted section informs you of the way to get around this problem. The reason why resaving the assembly does not take 
through external references is because it is unwise to have two assemblies externally referenced to the same part, this can create 
Circular References.  
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SolidWorks Explorer 
SolidWorks Explorer is a program included with SolidWorks used to modify unopened parts, assemblies and drawings. It can be 
started as a standalone application or can be launch from within SolidWorks – Tools> SolidWorks Explorer* 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

A- SolidWorks Search Assistant- easy method to search files locally and over the 3D Content Central web directory (uses 

Windows Desktop Search) 

B- File Explorer Pane- shows the content of your computer is a Windows Explorer type fashion 

C- Document Information Pane- information about the active document 

D- Standard toolbar for setting options and help topics 

E- Property/ Operation tabs- for finding references, where a document is used, its configurations, hyperlinks, and an e-drawings 

3D representation 

F- Tags- add a tag (searchable property) to the selected document 

File Management Options 
When a SolidWorks document is selected from the File Explorer Pane, four icons will appear, allowing you to Open the document, 

Pack and Go the Assembly, Rename the document (as well as updating the references) and Replace the 
Component within an assembly.  
 

*Be on the lookout for SolidWorks Explorer within Windows Explorer. When you RMB on a SolidWorks file in Windows Explorer you 
should find a SolidWorks entry in the list, this allows you to rename without the need to open the SolidWorks Explorer software. 
Further information on File Management can be found under the SolidWorks help topics and training courses specifically targeted 
towards Product Data Management detailing the Workgroup PDM and Enterprise PDM suite of products 
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